Announcement

Collapse
No announcement yet.

Unidentified leaves problem.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HELP! Unidentified leaves problem.

    Hi all, I have a problem with leaves on young plant. I can't find any information about the symptom. Anybody can assist in finding what is wrong?
    Medium is Coco, food is General Hydro (Flora series) with Cal-Mag, in a tent with LEDs canopy, seeds is Bubba Kush. I have used this equipment for few years and didn't had any problems.

    There are no bugs or powder, just this strange spots. This has been noticed about a week ago.

    Please advise if you know what is going on.

    Thanks!

    JC
    Symptome: Click image for larger version  Name:	Leaves 1.jpg Views:	0 Size:	90.3 KB ID:	576360 Click image for larger version  Name:	Leaves 2.jpg Views:	0 Size:	81.1 KB ID:	576361 Click image for larger version  Name:	Leaves 3.jpg Views:	0 Size:	103.7 KB ID:	576362







    Added pics




    Click image for larger version

Name:	Pot A.jpg
Views:	89
Size:	108.4 KB
ID:	576696

    Click image for larger version

Name:	Pot B.jpg
Views:	92
Size:	102.0 KB
ID:	576695
    Attached Files
    Last edited by JCD; 09-19-2022, 07:32 AM.

    #2
    Howdy JCD, I cannot see enough detail in the photos that you posted, can you post a couple of higher resolution images, including the underside of the leaves? It kind of looks like leaf miners, but I can't tell for certain. Also, is it on all of the leaves, or on just a few of them?
    Smoke weed,.....grow peace!

    Comment


    • JCD
      JCD commented
      Editing a comment
      Thank you for helping! The problem is only on top of leaves, underneath affected leaves is all OK. See added pics.

    #3
    Have you checked the Plant Problems page (https://www.growweedeasy.com/cannabi...oms-pictures)? I suggest always checking there first. Honestly, it's the best problems page I personally have found anywhere. It's the reason I joined the forum.

    Comment


    • JCD
      JCD commented
      Editing a comment
      Thank you for the link. I went there first before posting here. None of the pics shown corresponds to the problem I have.

    #4
    I think it is a PH issue but to be honest, that's what I usually see.
    Current Grow:
    2 Jack Herer, 1 Skywalker OG, 2 Gorilla Glue, 1 Northern Light, 1 Sweet Gelato
    Indoors, Soil, All Autos using staggered plant timing

    Comment


    • JCD
      JCD commented
      Editing a comment
      Ph is 6.0: I use distilled water with the nutrient schedule. I tested the Ph and it is 6.0.

    #5
    You have bugs.
    https://www.growweedeasy.com/cannabi...f-spider-mites
    https://www.growweedeasy.com/cannabi...roblems/thrips
    https://www.growweedeasy.com/cannabi...ms/leaf-miners

    Comment


    • JCD
      JCD commented
      Editing a comment
      Thank you for the links. I inspected the leaves with a strong magnifier and there are no bugs to be seem. The damage is only on top surface of the leaves.

Check out our new growing community forum! (still in beta)

Subscribe to Weekly Newsletter!

Working...
X