Announcement

Collapse
No announcement yet.

Unhappy plants

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Unhappy plants

    Hello there i really need your help i have this plant here its been 17 days since i put it on a 15 liter pot i keep the ph on the water 5.8-5.9 and the growth is extremely slow

    #2
    If it’s in soil that ph is too low

    Comment


      #3
      Its in canna coco

      Comment


        #4
        Do you think it could be phosphorus problem cause thats what im thinking?

        Comment


          #5
          Regardless of the medium, the PH is too low. This may also be causing problems with calcium/magnesium/iron up take. Raise the PH to 6.2-6.8
          Current Grow:
          2 LSD, 2 Skywalker OG, 1 Alien OG All Auto-flowering
          Soil in 5 gallon pots. Indoors,

          Comment


            #6
            Also, give it a dose of CAL-MAG.
            Current Grow:
            2 LSD, 2 Skywalker OG, 1 Alien OG All Auto-flowering
            Soil in 5 gallon pots. Indoors,

            Comment


              #7
              My tap water is hard so cant be calmag

              Comment


                #8
                Probably The EC is too high. I would reduce nutrients by a quarter, nutrient lock out its called

                Comment


                  #9
                  If I'm not mistaken the pH should be around 6.3 for the plant to utilize calcium correctly. If that's the case it could very well be Cal/Mag deficiency even with hard water. I'm on my first grow however so I'd wait for someone more experienced to answer ^^.

                  Comment

                  Check out our new growing community forum! (still in beta)

                  Subscribe to Weekly Newsletter!

                  Working...
                  X