Announcement

Collapse
No announcement yet.

Help Please

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help Please

    Hello Good People

    Please help me figure out what is going on with my plant. The two lower leaves on the plant seem to be having major issues. Its part of a DWC system of 14 plants. No PH issues that I can see of, PH been sitting at 5,7. all the other plants not displaying this issue. Im having some issues with the water temperature of the system which has been sitting at around 25°c for the last few days which is being attended to. Also there was a small pest issue and the plants were recently sprayed with organic anti-pest. Not sure if this is linked to either of these things or a separate new problem.

    Any help would be greatly appreciated as a first thing grower over here

    Thank You!


    Attached Files
    Last edited by MrCantSpellGood; 07-28-2021, 09:40 PM.

    #2
    More input..............know nothing about your grow. My gut says it's a pH issue. As an English major i think your spelling is fine.
    Started 9/9/21: 2nd grow: Hawaii Sativa MAUI auto x 3
    Finished Grow: Critical Mass photo - fem x 3 plus 1 clone same
    Medium: FF Coco Loco plus 30% Perlite in 5 gal cloth bags
    Space: 30x48x62 DIY cabinet lined w/space blankets
    Lighting: Bloomspect SS1000 Quantum board x 3 - 300 watts actual draw total
    Soil Supplements: Worm Castings, Guano, Crab Shell, Oyster Shell, Neem and Karanja Meal, Volcanic Basalt Dust (for minerals), Recharge root micros, ACV for organic pH down as my filtered tap water runs over 7.5 pH
    Ventilation: Vipospar 4" Exhaust Fan w/RH controller, 12" Carbon Scrubber
    Reptile Humidifier/Fogger w/same RH controller, bottom intake fan, 6" heater
    Cabinet on screen porch. N AZ @ 4000 ft.
    Old hippies never go away, they just
    Grow Their Own

    My salute to all who have served
    Semper Fidelis!

    Comment


    • MrCantSpellGood
      MrCantSpellGood commented
      Editing a comment
      Hey, thanks for that. Not displaying any PH issues on any other plants. Put some more information in about PH in the post. Let me know what else you need?

    #3
    The clear tubing and hole larger than tube will allow light into reservoir and cause root issues. I also noticed a drop on one of the upper leafs did you get nutrient water on the leafs with issues?

    Comment


      #4
      You need to lower your res temps to at highest 22 C, but you said you are addressing that. Its important because of the amount of dissolved O2 is lower in warmer water, and plants can get drowned. That said i dont think that is the issue here. I am not sure but I have a couple ideas:

      Maybe some light stress is causing leaf discoloration and curling. To me that is what it looks like the most but it's a little strange that the lower leaves are effected more than the upper, though i see potential slight cupping starting to happen to the upper part as well.

      Another thing that is concerning a little is that you said you used organics for pest control. Organics in hydro is bad, especially if you cant regulate res temps. It could be root rot. Check your roots and if they are unusually brown, slimy or stinky then you may have root rot from organic material getting into the res and inviting bacterial growth.

      Comment

      Check out our new growing community forum! (still in beta)

      Subscribe to Weekly Newsletter!

      Working...
      X